Don't like the adverts?  Click here to remove them

Had my first break down.

MailEscort

New Member
Joined
Jul 4, 2020
Messages
16
Country Flag
united_states
I have been having an intermittent starting problem, clicks no crank. I had successfully ignored it since it always eventually started. Yesterday it stopped being an intermittent problem...in the middle of my mail route. Thanks to some links and GOOD advice posted on this forum I got it apart, borrowed some tractor parts and reassembled it in time for the route this morning!

Cheers to you all! Snapchat-333098216.jpgSnapchat-136979029.jpg
 

StarCruiser

Well-Known Member
Supporter
Guru
Joined
Oct 7, 2014
Messages
11,850
Garage
Country Flag
uk
Yep! They do munch through the contacts. When you order replacements, order the extended ones that go part way round. And don’t forget to studlock (low strength) the three screws on the cover when you put them back. I had a small fire when I didn't studlock mine. !:scared-eek:
 
Last edited:

StarCruiser

Well-Known Member
Supporter
Guru
Joined
Oct 7, 2014
Messages
11,850
Garage
Country Flag
uk
I trust you were able to minimise damage to little more than embarrassment, given you probably had an array of equipment to put it out? :pray:
 

Firewout

Well-Known Member
Joined
Oct 3, 2014
Messages
837
Garage
Country Flag
belgium
Ehm, it was on the inspection pit of the MOT. Didn't pass....
 

StarCruiser

Well-Known Member
Supporter
Guru
Joined
Oct 7, 2014
Messages
11,850
Garage
Country Flag
uk
Ooops!! AR least you’re had plenty of access to get the extinguisher in there and hopefully bonnet up to disconnect the batteries.
 
Don't like the adverts?  Click here to remove them
Top