KZJ78 ECU.. no O/D and slow shifting

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
Hello Experts!
I am new to this forum- so thanks for your patience and any and all help!

I recently bought a KZJ78 here in Kenya- i have noticed several issues..

1. the A/T is slow to shift- especially when the truck is cold. 1st to 2nd is the worst but 2nd to 3rd is also slow-

2. No O/D

I (and a couple of mechanics) have tried several things to improve the slow gear changes and to get O/D... But just today i think i have discovered something.... The ECU unit in this truck is 89661-3D100.... which seems to be from a Surf, right?

I think that the KJZ78 should have instead the 89661-60250 ECU... right?

Or do i have wrong info?

So I think that i need to find the 89661-60250 ECU... NOw..... I have also read that these units are very rare- which is probably why someone installed the similar but different ECU.. Anyone know where I can get the correct unit?

Thanks!
Ken
 
Last edited:

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
Any advice?

Do you agree that i probably have the wrong ECU?

If so, do you think that if i could find the correct one... the A/T will shift smoother and even into O/D?

Thanks for any advice,
 

wobbly

Well-Known Member
Nov 27, 2010
2,637
88
48
Gods own Somerset, home of Alfred the Great!
Garage
Hi

You are correct, it has the wrong ecu, and as the ecu controls the gearbox it will cause you problems.

You are also, unfortunately, correct in that the 60250 is as rare as rocking horse poo.

Now, the only thing I can think of, there was a guy on here based out in Uganda who had a spare which he had refurbished, he may be able to help, downside is I cant remember his username, so you need to start searching this section......

I will have a play with ebay and see if anything crops up, in the meantime I suggest you put it on here as a Wanted, also on the i8ate mud forum, altho thats mostly north american, you never know.

Problem is that it is a Japan market model, only exported as a grey export, so there werent stocks of spares for the rest of world made.

Good luck.

Pete
 

wobbly

Well-Known Member
Nov 27, 2010
2,637
88
48
Gods own Somerset, home of Alfred the Great!
Garage
Last edited:
Don't like the adverts? Remove them by becoming a supporting member.   Click here

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
thanks Pete!

I am glad to know that the ECU really is the issue... but not so glad to know how difficult they are to find... I suspect the original one went bad and the previous owner swapped it out for one from a surf and now it's my problem... I should have noticed it when we test drove- but somehow we missed noticing...

I will keep looking here and also try to find the guy in Uganda...

Thanks so much!
ken
 

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
Thanks so much Wobbly! I followed your clues and talked to Samir on the ih8mud forum... he had sent his spare to someone in New Zealand -through the offroad-express forum i was able to find Calvin in NZ who knew Alan who had a spare ECU for this truck! I contacted Alan and sure enough he had one for sale!!! After some dialogue back and forth I sent the funds and he posted the ECU to Kenya...

OK long story short- I installed the ECU this A.M. and sure enough it has solved my problems!!! She shifts as she should even hitting O/D and now at 100kph the RPMs are around 2200-2400 instead of the 3200 she was running before.

SO I want to say thanks Pete!:clap: You sent me on a round-the-world journey that led me to the part and the solution!
 
Last edited:

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
Yes indeed it is a small world! So my joy was short lived... the cruiser ran perfectly for one whole day... curiously the next morning she wouldn't start- So the only thing that had changed was the ECU- so I put the old one back in again and it fired right up... but then my gearbox was again acting up...:icon-cry:

So later that evening when i got a chance I opened up the replacement ECU and sure enough as you have already guessed the caps were blown... Eventually a few days later I managed to make my way to downtown Nairobi where you can usually find about anything electronic... I found a guy who repairs tvs, dvds, radios, and everything else... I gave him a list of the caps and he agreed to find them and do the replacement work... Set me back 2500 Kenya Shillings (less than $30 USD).

Now this morning I was able to get the ECU put back in and amazing!!! it is again like new!!

I am so indebted to everyone on these forums who has contributed their ideas and advice. Thanks so much!
 

tommi786

New Member
Nov 11, 2015
46
7
8
Nairobi, Kenya
Hi myers. I am based in Kenya and also need someone to fix my ecu - same part No as your replacement one - 89661 60250. Can you please share with me details of your electrician friend? I also funnily have a spare surf ECU which works fine except for gears and am wondering if caps can be removed from that and put into my spoilt ECU. Any advice very welcome.
 

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
Kenya ECU repair

Hi myers. I am based in Kenya and also need someone to fix my ecu - same part No as your replacement one - 89661 60250. Can you please share with me details of your electrician friend? I also funnily have a spare surf ECU which works fine except for gears and am wondering if caps can be removed from that and put into my spoilt ECU. Any advice very welcome.

Tommi,

I will private message you the contact for the electrical guy that sorted me out.. Are you in Nairobi? This guy is in town on Lithuli rd.. I used a magnifying glass and found the details of each of the capacitors and the numbers down... took the ecu and the list of caps to this guy- he went away with my list and returnd in about 30 miinutes and then he removed the old ones and installed the new ones.. I think I payed him a couple thousand KSH.
 

tommi786

New Member
Nov 11, 2015
46
7
8
Nairobi, Kenya
now gear shifting issues.....

Hi all. Thanks to myers have resolved the engine running issue with the ECU - had to transplant a resistor from my spare surf ECU.

New issue now - gear shifting is a little erratic - hops between first and second when idling and very slow speeds. Was not an issue earlier or with the surf ecu..... Also the lower board in the ECU seemed to be really messed around with by whoever opened it up before me. Caps were changed but badly etc.

Question : the lower boats on this ECU appears identical to the Surf one. The upper board which looks fine has all the chips which I guess control the gearbox. Can I swap the upper board from my ECU onto the Surf ECU? Its connected by a couple of ribbons. Any suggestions please?

Also now desperately looking for a second hand ECU to resolve this fully and properly. (89661 60250) can anyone help? Or am I best placed retaining the Surf ECU and instead changing my AT for one from a surf so that great change and o/d does not fail?
 
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks