tom mitchell

New Member
It's my birthday!
Joined
May 4, 2017
Messages
5
Country Flag
united_states
Hi,
I'm new here and to my 2002 LC...
GPS unit was inop when I got the LC last fall, the prior owner said it fail about two years ago.

Suddenly last week the audio system died, no lights and the main screen just says no audio input.
Fuses are OK, input power main and ACC are OK..switch in radio works (ohms out)

Dealer "thinks" that maybe the GPS/Nav unit is at fault. They want $300 for a DVD and then $$$$ for a new nav unit, yet they are guessing.
I read somewhere (I can't find it again) that someone took a newer unit (2015) and installed it.
I found that if I pull the radio, climate controls don't work.
I found a youtube video where a guy installed a JVC (along side the old radio), yet no details on wiring changes.

Anyone have some options, ideas etc.
I can't afford big buck for a complete system, as I also have to install a new steering rack, new axle boots, cap rear A/C (line corroded out, I have the new one, yet wow to install it)
 

Shayne

Well-Known Member
Guru
Joined
Feb 2, 2013
Messages
13,610
Nobody can help without knowing exactly what Landcruiser you have Tom , year engine and series will help those who can help tremendously :thumbup:
 

tom mitchell

New Member
It's my birthday!
Joined
May 4, 2017
Messages
5
Country Flag
united_states
Augh gee, I feel really :neutral:dumb...sorry
It's 2002.
As for series (I believe, I'm a learning) is J100 or 100
The engine is gas 4.7 l V8, with automatic transmission.
 

StarCruiser

Well-Known Member
Supporter
Guru
Joined
Oct 7, 2014
Messages
11,810
Garage
Country Flag
uk
Don't feel dumb Tom, we are here to help and this is a really friendly forum. There is in fact an 'introduce yourself' section with a handy template I believe, where you could just tell us a bit about you and your new truck. Then if you have a look at other people's signature lines and update yours with some info this then helps folks in the future.

To your radio, firstly, its generic info I give here as I'm not familiar with your radio/nav system. Do have a search on here if you haven't already BTW.
Some things to try.
Check the power to the sat nav and the head unit actually at the wire going into the unit. Use a multimeter and check to a known earth, also check for a good earth to the unit. Check the acc input too. There may be fuses on the actual unit itself so check these with a meter set to ohms. Sounds like you've done most if not all of this, I'm just beginning at the beginning if you like.
If this fails to show up any problem and wiggling plugs and wires give no sign of life then it does sound like the head unit has died. You have four options. A new one from MrT, expensive. A new one from Amayama or Partsouq, less expensive if available. A unit from a salvage vehicle at a breakers yard. Or open it up and check individual components. Chances are, someone with some electronics expertise could find the problem which often lies in the power supply side of these things. If it's not surface mount components you might have a fighting chance at getting it repaired, otherwise it's replacement only by the sound of it.

Good luck with it.
 
Don't like the adverts?  Click here to remove them

tom mitchell

New Member
It's my birthday!
Joined
May 4, 2017
Messages
5
Country Flag
united_states
Thank you.

Live power (R36 pin 1) to the radio is OK. When I turn on ACC the secondary power (R36 pin 11) is there.
I'll have to check the ground and now that I know the NAV unit is integrated (even though it's been inop for 3 years) I'll check power and ground there.
There is also a 6 disk CD unit in the console and someone suggested that's where the amp is.

I'm still trying to determine the plugs.
I believe I have R36 and LX470. There appear to be two ways the R36 can be wired.

The radio comes out seperatly, yet if I remove it the climate controls fail to display as it's somehow integrated.

2017-04-30 19.49.32.jpg
 

tom mitchell

New Member
It's my birthday!
Joined
May 4, 2017
Messages
5
Country Flag
united_states
Kenwood KMM-BT518HD radio

Just in case anyone else wants to know.
Since the nav unit and radio were not working, the only thing that the display screen is used for is, climate controls.(what a waste).
Today I installed a Kenwood KMM-BT518HD radio, so far so good.
FYI I didn't bother trying to run anything through the old display
I'm still trying to decide if I'll bypass the AMP and or remove the 6 CD player.

2017-05-30 16.58.52.jpg
 
Last edited:

DebtFreeCars

New Member
Joined
Feb 1, 2021
Messages
2
Country Flag
united_states
Toyota Sienna, Highlander, Tundra, 4runners and Sequoias. Land Cruiser Lexus LX470 LX570 GX460 LS430 LS460

Toyota Power Folding Mirror repair

Toyota GPS Navigation NO POWER Repair
 
Top