Gearbox Oil Cooler

Graham Whitehead Aug 7, 2019

  1. Graham Whitehead

    Graham Whitehead New Member I am in great_britain

    33
    3
    8
    Map
    I have just replaced the oil filter in the auto box, after a few miles I lost all drive, to the point i called out recovery to bring it home

    I am wondering of the filter could be at fault, or my fitting of it, as after taking off the pipe off the lower rad, there is no oil pumping in the slightest, just the odd drip, the levels were checked and were fine with engine running and hot

    I am at a loss

    Could the torque converter of lost fluid, if so how is it filled ???
     
  2. Shayne

    Shayne Well-Known Member Guru

    11,417
    3,625
    113
    Map
    I know nothing about auto boxes but because i can see your desperate to get this sorted i will say if it were me i'd just put as much oil in it it as i could physically fit , maybe jacking it up to get a bit more in , in the hope it would be forced to get where its supposed to be to restore drive . You can always let some out once its working - if it works ?
     
  3. Graham Whitehead

    Graham Whitehead New Member I am in great_britain

    33
    3
    8
    Map

    Did that, went into gear, then lost all drive and still none pumping around cooler, will take the sump off again tomorrow, see if i made a boo boo with the filter
     
Don't like the adverts? Become a supporter

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice