Don't like the adverts?  Click here to remove them

Hesitation on acceleration

Curl

New Member
Joined
Dec 10, 2016
Messages
5
Country Flag
australia
Hello All.
I have a 105 Series 4.5L Petrol Auto.
It has developed a slight hesitation from take off, and sometimes also when kickdown is applied.
Only appears to be a problem from take off and not at speed.
Before I remortgage the house to pay Toyota to have a look at it, I thought I might ask you fellas out there in case its just a simple solution that someone might know about.

Cheers.
 

Michael80

Active Member
Joined
Oct 17, 2020
Messages
55
Country Flag
uk
I would check the rubber intake pipe from the air filter to the inlet manifold as they split after the MAF sensor.
It would be using unmetered air and could cause the problem you have.
You wouldn’t have an engine light come up either.
 

Curl

New Member
Joined
Dec 10, 2016
Messages
5
Country Flag
australia
Thanks for the help.
I'll check it out and let you know.
Cheers.
 

Curl

New Member
Joined
Dec 10, 2016
Messages
5
Country Flag
australia
No, looks pretty good.
I did renew it a few years ago.
Any other suggestions?
Cheers.
 

Michael80

Active Member
Joined
Oct 17, 2020
Messages
55
Country Flag
uk
I would start with checking for any split rubber hoses etc all over the engine.
Are you running it on LPG?
It could be a multiple of things, how many miles has it done and since it’s last service?
Spark plug condition?
Ignition leads
Distributor cap
Fuel filter
It would also help to know if it’s running rich or lean.
 

Curl

New Member
Joined
Dec 10, 2016
Messages
5
Country Flag
australia
Ok.
I'll check the hoses first, then look at the ignition.
Previously run on LPG, but been disconnected for some time now.
260,000 klms.
 
Don't like the adverts?  Click here to remove them

Curl

New Member
Joined
Dec 10, 2016
Messages
5
Country Flag
australia
This looks like the problem.
All plugs except 1 and 4 have oil on them.
I guess that would mean there's a problem with seals/gaskets under the Rocker Cover?
 

Attachments

  • IMG20220110135043.jpg
    IMG20220110135043.jpg
    358 KB · Views: 5

Michael80

Active Member
Joined
Oct 17, 2020
Messages
55
Country Flag
uk
Hi,

The plugs dont look too bad, I would replace them with a set of NGK, never been a fan of Champion plugs.
It would be worth checking the rotor arm and distributor cap etc for wear and carbon build up.
A new rocker cover gasket will help with the oil in the plug holes but I dont think it would of been doing too much harm.
 
Top