Don't like the adverts?  Click here to remove them

100 SERIES A750F TRANSMISSION 4TH TO 5TH NO UPSHIFT & NO LOCK OUT

Donna Ware

New Member
Joined
Dec 15, 2017
Messages
4
Country Flag
australia
Hi all
We bought a 2006 Sahara in July 17. Picked up Aug from Toyota. Sep, replaced Chipit Chip with a DTE chip. Have driven about 1000k before transmission stuffed itself. Oct had transmission rebuilt. No upshift from 4-5.

Went to Toyota to diagnose. No fault found. Went back to transmission rebuilder...no fault found. Went to Chip installer...no fault found.

Do it ourselves...found a few faults....Turbo boost sensor stuffed. Throttle motor controller - pins corroded (now cleaned). L4 position switch replaced. Still no 5th.
Using ATF WS oil in transmission.
We have borrowed a Snap on diagnostic kit and checked all pinouts. Found a couple more issues but we are yet to find out why upshift to 5th not working. It has intermittently worked a couple of times where it has shifted to 5th and locked in but with no explanation as to why.

Does anyone have any ideas as to what could be wrong?

If we find something in the mean time, I will give you an update.
 

Donna Ware

New Member
Joined
Dec 15, 2017
Messages
4
Country Flag
australia
UPDATE

We now have 5th gear. We will see how it goes for the week before scream hallelujah. We took the DTE chip out and the turbo smart booster valve off the waste gate pressure control line. It worked straight away. We had that chip fitted and then about 150kms later we blew a tranny. So we will see if this is it.
 

John Jennings

New Member
Joined
Jun 14, 2018
Messages
6
Country Flag
australia
Hi Donna we have a 2003 sahara 5spd auto that is failing to lock into 5th all others gears are fine.
Vehicle recently lost all drive and mechanic said "rod had popped out" in pan never had 5th since and mechanic is stumped.
Have you any ideas?
Regards John
 

Donna Ware

New Member
Joined
Dec 15, 2017
Messages
4
Country Flag
australia
Hi Donna we have a 2003 sahara 5spd auto that is failing to lock into 5th all others gears are fine.
Vehicle recently lost all drive and mechanic said "rod had popped out" in pan never had 5th since and mechanic is stumped.
Have you any ideas?
Regards John
Gidday John
Not sure what engine is in your vehicle but mine is 1HDTFE.
In the end it was the connector on the throttle motor controller which a bad connection this showed as a code on the engine side code p1222. Even after completing a full ecu pin out on engine and trans i was stumped, as it passed. I can only assume that every time i moved the conector it pinned out OK.I replaced the connector and no further issues, about $25 on ebay for a 1JZ,2JZ & 1UZ. My suggestion is find someone with a scan tool and check the codes current and stored. If there is no codes then drive the vehicle and read the live data watching for the trans to request 5th gear electronically, if it requests it electronically and still no 5th gear then it could be and internal issue. Although from all my findings there is only 1 other thing that could lock out 5th gear and that is the low range switch on the transfer case. i can't remember if the transfer switch is normally open or normally closed but a simple check is unplug it and drive if no change then bridge the plug and try again. This will show no code.
Not sure what state your in but I am in Perth W.A. if you are anywhere near Bayswater Victoria I highly recommend Wholesale Automatics. Even if it's for a brain pic they are a great company with insane knowledge.

Hopes this helps you and good luck.
 

John Jennings

New Member
Joined
Jun 14, 2018
Messages
6
Country Flag
australia
Gidday John
Not sure what engine is in your vehicle but mine is 1HDTFE.
In the end it was the connector on the throttle motor controller which a bad connection this showed as a code on the engine side code p1222. Even after completing a full ecu pin out on engine and trans i was stumped, as it passed. I can only assume that every time i moved the conector it pinned out OK.I replaced the connector and no further issues, about $25 on ebay for a 1JZ,2JZ & 1UZ. My suggestion is find someone with a scan tool and check the codes current and stored. If there is no codes then drive the vehicle and read the live data watching for the trans to request 5th gear electronically, if it requests it electronically and still no 5th gear then it could be and internal issue. Although from all my findings there is only 1 other thing that could lock out 5th gear and that is the low range switch on the transfer case. i can't remember if the transfer switch is normally open or normally closed but a simple check is unplug it and drive if no change then bridge the plug and try again. This will show no code.
Not sure what state your in but I am in Perth W.A. if you are anywhere near Bayswater Victoria I highly recommend Wholesale Automatics. Even if it's for a brain pic they are a great company with insane knowledge.

Hopes this helps you and good luck.

Thanks Donna i went for a drive this morning and everything was fine it went in and out of 5th flawlessly so will wait and see what develops.

Regards John Jennings
 
Top