1HD-FTE MAF sensor pin out

Miro

New Member
I am in bulgaria
Sep 27, 2017
11
0
1
Sofia, Bulgaria
Does anyone know if the process of testing the mass aif flow sensor (22204-27010) on 1HD-FTE, is any similar to the procedure outlined here:

http://troubleshootmyvehicle.com/toyota/1.8L/how-to-test-the-maf-sensor-1

Particularly, if the pin out of the 22204-27010 MAF sensor matches the described on the above link, in the table at the bottom of the page ?

According to this, the MAF sensor signal wire is the one labelled as number 3. In my case the third wire of the sensor gives a constant 12.4V, and none of the other wires has voltage level of around 1V at idle. So either the MAF sensor on my truck may be faulty, or it is supposed to be tested in a different way.
 

Jmacd

New Member
I am in uk
Apr 8, 2014
36
4
8
Pin 3 should be between 9 - 14v.
Between VG and ground should be 0.2v -4.9 v with engine running.

IMG_3538.JPG
 
  • Like
Reactions: Miro

Miro

New Member
I am in bulgaria
Sep 27, 2017
11
0
1
Sofia, Bulgaria
Thank you very much.

I was able to test the voltage on mine today. Between pin 5 of the MAF connector and ground, while idling (600 rpm) I have 2.1V and increasing gradually to about 3.2V at about 2000 rpm. So the MAF sensor seems to be responding well, although the voltage at idle may be a little to high. May have to repeat the measurement when the engine is cold, just for comparison.

Btw, what is the number of the manual from your picture, or do you by any change have it in electronic format :) ?

Thanks again for your help.
 

uHu

Well-Known Member
Supporter
I am in norway
Mar 7, 2010
2,089
444
83
Oslo, Norway
Attached.
Better if you include model (code) and production month in your signature. You will get better help. There are quite a few changes over the years, and differences between markets.
 

Attachments

  • Like
Reactions: Miro
Don't like the adverts? Remove them by becoming a supporting member.   Click here

Miro

New Member
I am in bulgaria
Sep 27, 2017
11
0
1
Sofia, Bulgaria
Thank you uHu, thanks alot. The attachment is priceless!

I have updated my signature with the details, extracted from the truck's VIN.
 

uHu

Well-Known Member
Supporter
I am in norway
Mar 7, 2010
2,089
444
83
Oslo, Norway
The MAF sensor on hdj100 appeared from 8/2002 production for Europe only, it looks like. Earlier models, and other markets, had none, if I understand the FSM correctly.

What is the problem with your engine? There are a few good techs reading this forum, so, with a bit of meat, they might appear on the stage.
 

majindi

New Member
I am in australia
Nov 5, 2017
4
1
1
vlcsnap-2017-11-12-09h55m19s375.png
Put on an Ogo map/maf enhancer controller will adjust air fuel anyway you want l use one on my 100 running on hydrogen hybrid
 
Last edited:

Miro

New Member
I am in bulgaria
Sep 27, 2017
11
0
1
Sofia, Bulgaria
Apologies for the absence.

@uHu - Thanks for asking. While I was answering here, I realized the replay became massive, so I decided it would be better to open a new thread for the problem I am trying to solve. Please take a look at:

https://www.landcruiserclub.net/community/threads/1hd-fte-white-grayish-smoke.149050/

@majindi Thank you. I prefer to keep a stock setup while I am trying to sort out the current issue with my engine. Hydrogen hybrid does sound tempting though. I have been considering this in the past primarily for the potential carbon cleaning effect.
 
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks