Head lights

Dave007

New Member
Joined
Sep 29, 2016
Messages
3
Country Flag
australia
Can anyone help me out my head lights work fine on both high and low beams BUT when I flash hi bean no lights at all yet the blue hi beam light on the dash works as does the LED light bar which is hooked to hi beam
 

Dave 2000

Well-Known Member
Joined
Mar 26, 2010
Messages
2,743
Country Flag
spain
There are two relays in the box under the bonnet, one brown one black and they are side by side. They are responsible to change over the beam and flash IIRC. Pull them both out and check the connections in the fuse box, and then plug back in. I cannot remember if the ignition has to be on (my dashboard is out at the moment) but with it on just in case, have someone hold the stalk in the flash position and move the relays about, you may catch the headlights flickering. This is becoming a well known fault on the 80, the contacts normally burn and stick on the black relay, I always replace as a pair.

Given the dashboard light comes on tells you the stalk is doing it's job, so the relays would be the next port of call.

regards

Dave
 

Dave007

New Member
Joined
Sep 29, 2016
Messages
3
Country Flag
australia
There are two relays in the box under the bonnet, one brown one black and they are side by side. They are responsible to change over the beam and flash IIRC. Pull them both out and check the connections in the fuse box, and then plug back in. I cannot remember if the ignition has to be on (my dashboard is out at the moment) but with it on just in case, have someone hold the stalk in the flash position and move the relays about, you may catch the headlights flickering. This is becoming a well known fault on the 80, the contacts normally burn and stick on the black relay, I always replace as a pair.

Given the dashboard light comes on tells you the stalk is doing it's job, so the relays would be the next port of call.

regards

Dave
I only have 1 relay in with the other fuses and relays and I have already replaced that one
 

Dave007

New Member
Joined
Sep 29, 2016
Messages
3
Country Flag
australia
I only have 1 relay in with the other fuses and relays and I have already replaced that one
 
Don't like the adverts?  Click here to remove them

Dave 2000

Well-Known Member
Joined
Mar 26, 2010
Messages
2,743
Country Flag
spain
What colour relay? I am a little confused here. Every 80 I have worked on has two relays coloured as above.

regards

Dave
 

StarCruiser

Well-Known Member
Supporter
Guru
Joined
Oct 7, 2014
Messages
11,810
Garage
Country Flag
uk
Could it be a relay is missing perhaps, hence the non working main beam flash?

I think this calls for photos…
 

stumog

Well-Known Member
Joined
Oct 3, 2012
Messages
3,510
Country Flag
england
Mines doesn't flash unless head lights are on.
 

Chris

Super Moderator
Supporter
Joined
Feb 24, 2010
Messages
17,310
Garage
Country Flag
europe
Mine flash even without the ignition on
 

Dave 2000

Well-Known Member
Joined
Mar 26, 2010
Messages
2,743
Country Flag
spain
Thanks for that Chris/grantw, as mentioned mine is still in bits at the moment so and was unsure.

regards

Dave
 

Dave

Well-Known Member
Joined
Apr 6, 2010
Messages
215
Some markets had power through the stalk, and not the twin relay setup the UK had. But the stalk switches don't like the power, so can melt and arc.
 

Dave 2000

Well-Known Member
Joined
Mar 26, 2010
Messages
2,743
Country Flag
spain
Not come across that version yet Dave, the OP has no vehicle info up soooo?


regards


Dave
 

Cruiserdude

New Member
Joined
Oct 26, 2017
Messages
47
Country Flag
great_britain
Just to resurrect this thread....

Dave, can I ask where you managed to source the relays please. I've taken my brown (headlight) one out and cleaned the contacts but it hasn't fixed the issue. It seems that after a period of time on main beam, mine will fail to come on the next time until it's had chance to cool down, I suspect? before I can re-select main beam.

Any help would be most appreciated.

Cheers,
Mark

Ps. Dave, where abouts is Murcia are you, I often visit my folks in La Manga, you anywhere near there?
 

Dave 2000

Well-Known Member
Joined
Mar 26, 2010
Messages
2,743
Country Flag
spain
You need to get both the Black and Brown as a pair side by side. The contacts heat up and loose tension, the heat burns out the relays.

Go for OEM, not cheap but worth the extra.

I have built a wiring and relay setup that is virtually plug and play. It gives brighter headlights and takes the load off the OE system. Fancied making and selling a kit to make a few extra quid but I simply don't have the time.

Regards

Dave
 

Cruiserdude

New Member
Joined
Oct 26, 2017
Messages
47
Country Flag
great_britain
Hi Dave,

Many thanks for the reply and your tips. Your own system sounds very interesting - reckon I'd have had one of those from you - is it easy enough for a DIYer like me to make perhaps? If you're too busy would you comsider sharing the details?

Cheers,
Mark
 
Top