Don't like the adverts?  Click here to remove them

LJ70 Alternator not charging

Si LJ70

New Member
Joined
Jan 5, 2021
Messages
28
Country Flag
great_britain
Hi,

I have a refurbished and tested alternator fitted to my LJ70. It will give 14v on the bench (according the auto electric guy) but nothing in the LC. Also the battery light does not come on when the ignition key is turned. Battery voltage gauge works. I have checked the battery LED on the instrument cluster and its good. Fuses are good (charge and engine). It seems the alternator is not getting the signal to start charging. Next I am going to check the voltage from the ignition switch. Just wondered if anyone else had had this issue?

Cheers,

Simon
 

Iwan

Well-Known Member
Joined
Mar 28, 2011
Messages
1,626
Country Flag
wales
As it's the round light truck version there's an external voltage regulator mounted on the inner wing by the airbox, they have a domed metal casing.

About 20 years ago my Dad bought a replacement one from Millner which was a modern replacement it's sealed up all electric unit compared to the original more mechanical one.

It could be the original external voltage regulator thats at fault..
 

Iwan

Well-Known Member
Joined
Mar 28, 2011
Messages
1,626
Country Flag
wales
Just check out if the wiring hasn't been altered there... I actually still have the unit here so can add a picture of the connector and the replacement.

Just your symptom sounds familiar to the one from many moons ago.. refurbished alternator and no charging!
 

Si LJ70

New Member
Joined
Jan 5, 2021
Messages
28
Country Flag
great_britain
Actually the guy who refurbished it said it had an internal regulator in the alternator. It must be poor connection from the ignition to the 'exciter' connection on the alternator. The wiring had been messed about with on the car so need to check the continuity on everything.
 
Top