Don't like the adverts?  Click here to remove them

Activation remote control 80 series


New Member
Sep 29, 2021
Country Flag
I recently bought an 80 series and I don't know if it has an alarm or how to check it, also the central locking I don't know how to set it, I also changed the batteries and it still doesn't work, can anyone guide me how to check it? Thanks in advance.


  • WhatsApp Image 2021-09-29 at 12.11.57.jpeg
    WhatsApp Image 2021-09-29 at 12.11.57.jpeg
    132.5 KB · Views: 128
First things first. When you press the buttons does the little red light come on? If the fob isn't working then we're not going to get very far.
If the lights come on then that's a start. It just means that the alarm ECU and the fob aren't talking to each other.
That looks like the TVSS which was fitted to the 80 outside of the factory, but effectively commissioned by Toyota
It was professionally spliced into the wiring loom and a sounder fitted, typically in the wing. There is a battery in there that over time dies. It is actually replaceable with a bit of fettling but if the siren etc had had it, then frankly it's a waste of time trying.

This is one of those one step at a time fixes to find out what's going on. It could just be a fuse. People who have alarm issues get fed up and pull the fuse out to kill the system. A dying battery in the siren can cause it to go off randomly and really annoy the neighbours.

So, light on the fob yes no
If yes, try pressing and holding both button at one for a few seconds. This can sync the fob to the car.
If no, then we need to go deeper into the system

If you put the key in the driver door and turn it, it should fire all the door locks. if it doesn't then there is a central locking problem. Again maybe a fuse.

Start with that and let us know what happens
Yes, as Chris said that's a TVSS 3B alarm fob. The same system was also fitted to some other Toyotas, Avensis for one, of the same era. My siren gave up the ghost some years back but I got hold of a used one from an Avensis, changed the rechargable battery pack and it's worked a treat ever since. If you can't get the fob to "talk" to the ECU it may need re-pairing using the "program" switch on the ECU unit.. I've found that if the FOB battery is low it may still light the LED but not set/unset the alarm so try a new battery even if the LED lights but nothing happens. Also try cleaning the battery contacts in the FOB.
Last edited:
Thanks for the answers so far.

I changed the batteries 2x, it seems to have power. I followed a tutorial on a model similar (my is 97 followed 98) and it says that I have to look under the driver's seat for a module where it has a reset button, but I don't have that module under driver and passenger also, I'm still confused because I don't know where to look and what to do


  • 20210929_185634.jpg
    213.3 KB · Views: 97
  • 20210930_155433.jpg
    290.2 KB · Views: 132
TVSS programming......


  • Screenshot 2021-09-30 at 16.37.11.png
    Screenshot 2021-09-30 at 16.37.11.png
    473.5 KB · Views: 136
  • Reset.png
    581.2 KB · Views: 149
Module is under the central cubby box typically. Not the seat. I actually have the full installers manual for the 80 series TVSS somewhere. I'll see if I can find it.
Don't like the adverts?  Click here to remove them
That's the sucker.
Hi @Towpack,
Just reading this thread, as one of my FOBs stopped working recently and I had to do the old two button trick.

But it got me thinking!...... If some unscrupulous individual had a spare key fob and your truck was unlocked could they do the same?

My thoughts are obviously NOT, because I'm assuming that the TVSS and FOBs are unique and that the two button procedure is purely to reset units already programmed to each other?
New fobs can be added (max of 4) to the alarm ECU and old fobs removed but access to the ECU is required plus the vehicle ignition key. See the attachment in post No. 5.
Very useful thread. Thanks for all the info

I have intermittent central locking problems on my '97 and my system is clearly TVSS

I will try reprogramming the keys and see if that fixes things

Did you find that installers manual please, Chris?
Did you find that installers manual please, Chris?

Unfortunately Chris passed away a short while ago so he won't be able to help with that. However I can ask Claire to look out for it and see if it can be passed on.
Oh man that really sucks - very sad to hear that

I wouldn't want to bother her with something so trivial when she's got all that to deal with, I'm sure Chris had stacks of stuff