B9003 sat nav unit and fitting reverse camera

Adrianlle

Active Member
I am in great_britain
Oct 4, 2020
73
92
18
Glad it’s worked out and was nothing more aero than a run down batteries. Glad too that you’ve got the camera working after all that effort in the cold. I recollect now that I too had to play around with the camera settings on the headunit. That’s also where you turn on the onscreen guidelines fir the camera.
 

paulnanrod

New Member
I am in great_britain
Dec 7, 2020
44
72
18
So I thought it was the batteries - got home last night, charged them both to full. Started this morning fine, drove about 7 miles, started again fine after that stop. About 5 miles down the road a light flickered on an off a couple of times, I think it was the glow plug coil, but it only flashed briefly. Another mile or two down the a1 and the dash lit up - Airbag, handbrake, VSC TRC, VSC OFF and battery. My dash cam also was off charge and running on battery and the cruise control stopped working.

Managed to get to my garage and it wouldn't turn on again so it has been left there and I'll wait for the verdict....
 
  • Like
Reactions: karl2000

karl2000

Well-Known Member
Supporter
I am in great_britain
Apr 27, 2020
374
442
63
Hmmm maybe it is the alternator then - those symptoms would match - shame you didn't manage to get a voltage reading from the battery while it was fired up and running!

If the alternator doesnt work, all the electrics will just be going off your battery., and the voltage will be dropping as it drains.

Cruise control etc will stop working as the voltage gets low, so its all related.

Once its sorted, its worth getting a little voltmeter for inside, then you can always see at a glance what your current voltage is. You can then see immediately if you're getting less than 14 volts on startup, and you'd know if you've got a problem!
 
  • Like
Reactions: paulnanrod
Don't like the adverts? Remove them by becoming a supporting member.   Click here

paulnanrod

New Member
I am in great_britain
Dec 7, 2020
44
72
18
Yes I thought it sounded like it may now be the alternator and the flashing was down to the batteries draining. Will get one sorted for once it is back. Hopefully get it back Monday so will see what the outcome is.
 
Last edited by a moderator:

paulnanrod

New Member
I am in great_britain
Dec 7, 2020
44
72
18
That's beyond my capabilities and has to potential to make more problems than just the alternator! It's been left at the garage and I don't want it back until it can be driven back!
 
Last edited by a moderator:
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks