Don't like the adverts?  Click here to remove them

Intermittently working remote fob

larryseaman

New Member
Joined
Nov 4, 2021
Messages
14
Country Flag
england
Hi all, I'm having will some trouble with the remote fob on my Prado KZJ95 (1999). It's programmed and works to lock/ unlock the vehicle but works very intermittently. Even if I change the battery and it works well (but still not perfectly every time) it still very quickly becomes problematic and it also doesn't matter how close I get to the receiver. Sometimes I can be stood for a few minutes trying the fob before it works. Any ideas would be appreciated!
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england
I changed the two tactile switches in mine a few years ago. It improved matters for a while but something else was wrong and I just use the key these days as it's less bother. I got the switches from CPC-Farnell.
 

Attachments

  • 2945623C-A99B-450B-8CE4-C45DB6EB22ED.jpeg
    2945623C-A99B-450B-8CE4-C45DB6EB22ED.jpeg
    214.5 KB · Views: 14

larryseaman

New Member
Joined
Nov 4, 2021
Messages
14
Country Flag
england
I don't think it's a problem with the fobs so wanted to look at the receiver. Do you have any idea where it is on a UK 95 model Prado/ Colorado 3.0L diesel please?
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england
It's behind the dash above the heater controls. Can look up the instructions if you need them for reprogramming etc.

E3B73547-A009-4987-AFB8-9106FB3F0D97.png
 

larryseaman

New Member
Joined
Nov 4, 2021
Messages
14
Country Flag
england
Thank you for the speedy reply! I've just had a look and there's nothing in exactly that location but mine might have been moved due to a new stereo & Bluetooth device being fitted. I did discover this though.... Is this it?...
20221122_194524.jpg
 
Don't like the adverts?  Click here to remove them

Shayne

Well-Known Member
Guru
Joined
Feb 2, 2013
Messages
15,704
My D.I.Y fix

1669150924291.png

Punched out thin hard plastic like the box window kids toys come in and it fits perfectly inside my round fob buttons .
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england
I don't think that is the ecu you want. That does the immobiliser which matches the chip in the physical key to the coil around the ignition switch. The central locking and alarm ecu is separate and comes in two varieties TVSS III and TVSS IV and was often fitted at the dealer rather than the factory I think, hence the unit is cable tied on and can be put in various locations at the choice of the installer. I could be wrong about all of this as it was years ago when I tinkered with it. I remember the ecu had a green LED and a tiny push button next to it that I used to program a fob to it, does yours have them? I had to drill out a rivet to reveal the button etc.
 

larryseaman

New Member
Joined
Nov 4, 2021
Messages
14
Country Flag
england
Ok that's really helpful thanks. I'm still learning in all of this! You are definitely right that there should be another ecu for the wireless door lock control system. After doing a bit more research different owners of the 90 series are saying they are finding it in different locations which seems to line up with your thought about it being fitted by the dealer at a location of their choice?
It's looking like it'll be somewhere behind the central dashboard by the air vents or behind the steering wheel dash.
I'll keep looking!...
Thanks again.
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england
Had a search for the other info today and found the programming info and manuals (credit to the original poster "
knicko" of the programming info - not my work)

20171215-183812000-i-OS.png



20171215-183818000-i-OS.png
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england

Original link
 

MODVRS

Member
Joined
Oct 3, 2013
Messages
189
Country Flag
england
Just realised knicko's post about programming a fob is the first post in the first sticky thread in the 90 section, doh! Spent ages searching for it too.
 

larryseaman

New Member
Joined
Nov 4, 2021
Messages
14
Country Flag
england
Hi again MODVRS, thanks again for your help and for sharing the post from Knicko, it's incredibly helpful & detailed! Because of his post I was able to locate the TVSSIII unit hiding behind the dash... What a challenge!
I didn't find anything untoward in the box or wiring which was causing the intermittent working of the fob there so I went back to investigating my fob not thinking I'd find anything as I've checked it so many times. I took it apart to see the circuit board and the two buttons which were both lighting up when pressed so I usually concluded there mustn't be an issue, however I also noticed both buttons we're a little sticky with some tiny signs of grease there. I very carefully applied some isopropyl alcohol to the top of each button & pressed the buttons in/ out several times for it to drop inside the button and clean away any dirt/ grease inside. As I gently wiped away, careful not to affect the circuit board I noticed a fair amount of grease/ dirt coming off. To my amazement the fob has worked perfectly since!
I've had this issue for a few years now & 'fingers crossed' it looks like it's fixed.

Thanks again for your help & best wishes.
 
Top