Don't like the adverts?  Click here to remove them

Mysterious starting issue

Yorkshire4x4

Active Member
Joined
Aug 6, 2016
Messages
85
Country Flag
uk
Hi guys does any one know what is going on. Ilc90d4d auto on start up after 2 seconds it cuts off then it takes 6 to 7 attempts to start . Once its started its OK for about 3 or four days it then happens again. Once in motion its OK it hasn't cut off on me yet .
1. I've had my fuel pump serviced 2 years OK.
2. The two pipes at the top of the fuel tank were corroded and leaking so had them cut down and new rubber ones fitted . I've checked the boot and no leaks of diesel .
I changed both batteries early this year

I serviced the car last week could it be a dodgy fuel filter ?
Could be the starter motor on its way out ?
Any ideas any one ? Thanks in advance this forum is fantastic for help with landcruisers. My car is landcruiser colorado 90series d4d 2002
 

BobMurphy

Well-Known Member
Joined
Mar 1, 2010
Messages
1,727
Country Flag
scotland
It sounds to me like . . . . .

It starts - because its got some fuel in the pump.

It stops because its now sucking air.

It takes a lot of cranking to start because its drawing fuel from the filter housing / fuel tank.

Sounds like an air leak to me, classic symptoms of a pin hole in the fuel pipe near the tank. Are you sure your 'rubber hose fix' has an air-tight seal ??

The hoses get old and hard, then they don't seal when disturbed. I would re-make all the joints from the tank forward with some silicone sealer.

Then try again.

Bob.
 

Chris

Super Moderator
Supporter
Joined
Feb 24, 2010
Messages
17,669
Garage
Country Flag
europe
Agreed and you can also get leaks into the top of the fuel pump primer (on the filter housing)
 
Top