problem

  1. Boian

    Intermittent Acceleration D4d

    Help! An year ago there was something like intermittent acceleration on my 2001 D4d automatic Prado and the fix was SCVs. However this issue appeared again. I changed the SCVs again just in case, but its still the same. The acceleration hesitation and delay are most prominent when the car is...
  2. S

    LEAK! Unsure of what this is or how to fix! Please help

    Not the most mechanically minded but I have a leak in what looks like a coolant line but I am unsure. Is it an easy fix? If so can anyone link me to the part I will need. Thank you,
  3. S

    Automatic 90 series question

    Hello guys, I have a 90 series D4D 4 speed automatic. When I travel above 40mph and I release the acceleration, the rpm drops to idle speed, when I reapply the throttle, the rpm jumps back. At that moment, when I apply throttle and the rpm jumps back, I get a big hit, like something is loose...
  4. S

    Soon-to-be 100 Series owner...

    Hello knowledgable people... I've just posted an introduction in the usual place. Medium time lurker, finally signed up! After a recent stream of Audi/BMWs and getting my 4x4 fix from work trucks, I've decided to sell my 330d and look for a late 100 series to hopefully enjoy for many years...
  5. joshcork

    Central Locking not working in the morning

    Hi All, I've had my awesome Prado GXL Diesel for about 5 years and recently the central locking is too lazy in the morning or perhaps when cold to work. Once I've run the car for a while and later during the day its all good Does anyone else have this issue? Is the battery starting to fail on...
  6. antbainerz

    Automatic gearbox issues

    I am currently having a few issues with my Automatic gearbox in my 1998 VX3.4lwb. when setting off, pulls hard in first gear then you have to let off the accelerator for it to change up to the next gear. when it shifts up the gearbox feels like it shifts up 2 gears so the revs are around 1k...
  7. B

    1hdt rough idle, please help!

    Hi, I'll make it sort and sweet, i own an 80series 1hd-t rebuilt engine, (injector pump, injectors, turbo, engine 60*** ago) got a problem where the engine starts shaking badly at idle, Only sometimes, cold or hot, mostly hot. When it's running rough, you can feel the exhaust flow that...
  8. S

    flushing coolant on V6

    Hi, first time poster here, as is common, I have a problem....:oops: Had a radiator leak that dumped the coolant out the rad, stripped everything down and found small hole where transmission cooler rad had been rubbing and worn small hole. Repaired rad and tried to flush through as per...
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks