Don't like the adverts?  Click here to remove them

Iwan's lc5


Well-Known Member
Mar 28, 2011
Country Flag
An into to my lc5, it appears as it arrived. It's last mot expired on the 13th of March 2020. I believe it was last running correctly late 2019.


It has covered circa 94 000 miles.... it has full Toyota service history to 70 k miles and am very grateful for the forum member who donated it to me.


As all 120's look good on the upper side, this one is outstanding on the underside.. there's rust on the weld joints on the chassis, the rear behind the bumper and the front radiator support.
It has previously had some undercoating but it is flaking off the body. Thank fully it's not orange on the under carriage!

Since last use it has developed the no start syndrome, it fires momentarily then turns over very rapidly. And that's it!

When it arrived the dash was semi dissembled in a bid to get to the core of the electrical problem, but when I reassembled the dashboard and connected the batteries .. in a bid to just see what was going on. it fired straight up. ????


I managed to drive it 6 miles to my local fuel distributor who kindly let me hot wash the truck and then fill it with fuel, as the air suspension was leaking from one of the rear air springs it was a very slow drive running on the bump stops so don't know if it was running in limp mode.

Made it home and the next time I went to move it no start just the typical scenario of a faulty scv whether or not it was the culprit., I changed it to the revised longer one replacing the shorter one said to be unreliable as time goes by. There's a difference between the 1st and 2nd versions of the scv's the earlier pushes and the revised pulls.. and this occurs on every stroke of the firing of the engine. So indeed a very active component! And prone to wear.

I think that this is integral to the immobiliser as it cuts of the fuel supply and people have had the B 2xxx fault code resulting from having a faulty scv.


This is the last pic of it that I have but have swapped out the suspension to a pedders air suspension replacement coil rear and front swap too +50mm.

Have removed a 10 amp fuse and the air sus 50 amp fuse contained in the under bonnet fuse box and also have disconnected the connector from the air susp ecu which is housed in the passenger side lower kick panel it's the further most connector to the rear of the truck. This has deactivated the flashing air sus warning lights on the dash and the switch circuit. This is the guidance from pedders susp. The air suspension circuit is deactivated and not connected to the initial problem of no start.

This pic was taken on 3/07/23 and it then was apparent to have the capability of reading the codes on the truck... and this is where the troubles were extended. (before even working out the core issue with this 120's immobiliser) .. have activated techstream v18 but failure of connecting the vim module mini vci j2534.. which is an early 32 bit compatible interface which works best on earlier versions of windows, after much research it does work on a 64 bit windows 10 some do but some will struggle to enable techstream to connect to the ecu. Have seen a guy who has run this off a windows 10 64 bit with a windows xp extension to make it work

This is the beginning of this particular problem and only scratching the surface of the story so far but just an intro into what I have found out so far.. I really like this lc5 and it's condition so deserves for it to be solved..

More to come... :thumbup:
I've been trying to get my tech stream working last weekend... have it installed and activated eventually have subscription for 13 years after buying the activation code from a fella in Russia for $5 , but the mini vci isn't connecting to connect... my laptop is windows 10 on a 64 bit system... I've seen how it doesn't like this combination and to download "Multi MVCI Driver x64" .RAR file??? It's blocked by windows saying that it's corrupted and then deleted.

I think I need to open a .RAR ? file on my 2nd laptop to accept the download then it'll be attached to the tech stream (will need to delete the previous drivers that don't operate).. But been offered another dark green 120 which I'm going to buy tomorow... it needs some welding but starts and drives!

Ecu repairers don't touch pre 2008 120 ecu's as they are locked from factory.. there's an update for the 2008 120 invincible, I've been told on several occasions.

A hilux at 2006 can have the immobiliser deleted or flashed off as the ecu is not locked from factory...

It would be great to get round this problem with the 1st 120, there's lot's of obstacles to even get the codes out of it and then decipher the root cause of the problem?

A previous post on "Who's doing what maintenance"

I found this yt vid and thought "My problems are over!!!"

Little did i know that the ecu's are locked from factory on the earlier d4d 120's after attempting to get the guys with the ecu vans lined up to sort this out by remapping, immobiliser delete..etc. learned that an 08 invincible indeed has an up date.. a 06 hilux is modifiable because the ecu is not locked from factory..
Foeget whats already been said on this but make sure battery voltage is good as the immobilisers seem particularly sensitive to it. And i assume youve tried resyncing the engine and immobiliser ecus by bridging the pins on the OBD connector?

Engone ecu would be easy to swap if youve got a second similar truck (same transmission) - just swap it and resync
Yep have good voltage on the batteries, have gone around and cleaned the earths, before the engine light wasn't on but now it is..

Have previously bridged pins 4 and 13 i think it was, but to no success, you can also hold the key in unlock position on the drivers door for 30 seconds in a bid to get the correct key visable to the immo ecu.

How to disable the immobiliser Toyota Land Cruiser Serie 120 ? - [Leaving Land Cruiser Club]

This is quite a handy article which describes different methods.regarding non starts.

Have found a 2nd lc4 auto in green aswell, it's a 06 with 200k miles orange on the underside, poor bodywork and absolutely filthy inside.

So havent decided on that one yet....

Definitely want to extract the the engine ecu to open it up and see if there's any burnt components in there, but to have the ability to read the codes first is my initial objective to move forward with it..
Get the part number off your engine ECU - I've got a known good spare here, but theres a few different versions!
Don't like the adverts?  Click here to remove them
I finally received my VIM..


It's an OTC spx vim, It's quite a lot more of a unit than the mini vci j2534... I had to stick the stickers on tho!!


Techstream connected straight up with this module before connecting to the lc5. Not sure if the driver was already on techstream or I had downloaded it to attempt to get the former vim to connect. Either way it was satisfying to get connected up.

With both batteries charged connected to the lc5, a bit of a faf to identify the model but with auto connect and adding the vin number it was operating. Spent a while navigating around the laptop.

Initially all 32 ecus were found ran a full health check and what came back was b2799 and thats it. Ran 10 health checks but only received this code on runs 1,2,,5,9. Between these runs was getting connection errors which are the same as if the vim is not connected to the vehicle and the laptop back in the house.

Also "please ensure the ecu is connected correctly" which suggested that the ecu is only working intermittently.

From a bit of research last night found these points.

If the immo light is flashing before inserting the key and goes out when key is inserted then the key is being reconised by the immo ecu.

If the immo light is flashing before and still flashing after inserting the key then it is the key amplifier at fault and would give a code of b2795 "unmatched key code" also sugesting that the immo ecu is working.

If you get the b2796 code then thats the "no communication with immo system" which suggests that the immo ecu is faulty.

So I'm leaning towards the fact that the immobiliser circuit is working correctly and the engine ecu is f'd as it was connecting intermittently with techstream.

I still need to go around the wiring on the truck to eliminate that there's nothing blatantly amiss.

Another thing that I've noticed is that the drivers seat belt warning light is always illuminated.

There must be a reason why the engine ecu has this problem externally in the wiring for it to result in this scenario.

Any ideas would be greatly appreciated...
When the batteries are disconnected and put on charge for a day or more then when reconnected the immobiliser light will flash until the key is inserted.

Then turn the motor over as to start, take the key out and it still wount flash like it should.

It only flashes when the batteries are reconnected after being disconnected for a good amount of time.
B2799 is an open or short circuit between the transponder ECU and engine ECU. First thing to check is the wiring harness between the two - the specifics are in the workshop manual. See attached

Shouldnt be too bad its only two wires to the engine ECU. Check for continuity / resistance on your multimeter; if in doubt run a couple of patch wires between the two and see if that solves the problem.

It might also be worth a half page summary of the current problem, so that we all know where its at without going through the whole thread again! :)


  • 1491 B2799.pdf
    61.8 KB · Views: 5
Just in case you havent got this already!


    41.1 KB · Views: 24
  • 1484 B2780.pdf
    57.6 KB · Views: 21
    32 KB · Views: 30
  • 1482 TERMINALS OF ECU.pdf
    127.4 KB · Views: 31
  • 1481 LOCATION.pdf
    73 KB · Views: 27
    40.3 KB · Views: 23
  • 1479 PRE-CHECK.pdf
    48.9 KB · Views: 23
    33.6 KB · Views: 26
  • 1491 B2799.pdf
    61.8 KB · Views: 12
  • 1490 B2797.pdf
    33.6 KB · Views: 4
  • 1489 B2796.pdf
    55.6 KB · Views: 6
  • 1488 B2795.pdf
    30.7 KB · Views: 5
  • 1487 B2794.pdf
    29.8 KB · Views: 2
  • 1486 B2793.pdf
    30.9 KB · Views: 2
  • 1485 B2784.pdf
    51.7 KB · Views: 20
When the batteries are disconnected and put on charge for a day or more then when reconnected the immobiliser light will flash until the key is inserted.

Then turn the motor over as to start, take the key out and it still wount flash like it should.

It only flashes when the batteries are reconnected after being disconnected for a good amount of time.

Sounds like immobiliser ECU to me, but check the wiring for that B2799 first!
Just coming back to the obvious here which youve already checked but:

1) after youve charged the batteries whats the voltage? (Ie when the immo light flashes)

2) after youve attempted starting and the immo light no longer works whats the battery voltage?

3) if you attach a jump pack or external power supply, does the immo light work again?

4) whats the results of a load test on each fully charged but disconnected battery - ie how many CCA is it supposed to have and how many CCA does it actually have?
Thanks man, I shall follow the 1491 B2799.pdf later today but also on this pdf it does also state trouble area could also be in the ECM also..

This is a great resource will be taking a better look at this later today..
Just quickly checked the 1st battery that charged over night and swapped to charge the 2nd battery an hour ago and it's holding a solid 13.3v.

After attempting to start the power is a little lower voltage wise. But turns the engine over very quickly.. as if there's no compression, but there's no fuel being distributed.

The immobiliser light will never return back to flashing unless the batteries are disconnected for quite some time 12 hours plus. Even then previously it was hit and miss whether the light would be flashing after reconnecting the batteries.

Recently the last 3 times of attempting to start it has been flashing at 3 attempts. But key out and walk away no sign of it.

Does the Engine ECU/ECM notify the immobilise to activate as the key is being withdrawn?
A bit of a change of plan today!


Have taken the dash out in 2 hours, not too bad of a job centre console was much easier than first thought and after removing the radio etc in the middle was alright..


The immobiliser ecu is well out of the way and armoured! Would never be able to do any thing with the dash board in.

Very blurry shot.. Photo's with a video camera aren't the best!


So the circuit board is glued into the case but looking in it doesn't appear to have much wrong with it i.e. burnt

So am in a moment going to do the continuity tests armed with a multi meter and a laptop..

Am I correct in thinking that you test from the harness side with the plug unplugged?
You sent the dog in to sniff the problem out ?

Did indeed Frank! She correctly identified that I was working off an incorrect diagram...

Screenshot (79).png

The E10 connector on the fsm has 3 rows of pins and the one on mine has 4 rows 7 pins on the top row and 2 rows of 8 pins then a 4th row with 7 pins!

So a bit stumped by this! Had decent connections to the pins with a paper clip to fit into the pin slots and connect wires with crocodile clips to connect to the multi meter.

I connected up the freshly charged batteries and performed a "Will it start!" LOL but not a lot! Did find that if you press the alarm button thats by the centre rear view mirror.. key out and in it does infact fire for a second... Performed a sync with pin 4 and 13 for 45 mins and no change..

Impressively at the end of play the batteries read 12.62v...

I'm in a strong position now to send off the ECM and Transponder key ecu to be bench tested to get an opinion on whether or not which one is at fault??

Having opened up both of these ecu's in a bid to find any "fried" components, it at the end of the day has fried my brain! Good progress tho! :thumbup: