Don't like the adverts?  Click here to remove them

Won't start .

flint

Well-Known Member
Supporter
Joined
Mar 11, 2014
Messages
1,354
Should have used a pair of these.
iu-2.png
 

Towpack

Well-Known Member
Supporter
Joined
Oct 4, 2011
Messages
3,865
Garage
Country Flag
england
old pants make crap filters...


Maybe you should have used an old sock. I remember Bear Grylls, on one of his survival jaunts, filtering his own pee though his sock filled with charcoal from the fire. Mind you, he did say it tasted "like urine filtered through a sweaty sock" :laughing-rolling:
 

chapel gate

Well-Known Member
Supporter
Promoted Company
Joined
May 26, 2014
Messages
4,253
Country Flag
england
Christ Mike. What kind of Pants were they?......
might well of been the missuses.

i may of been working on the premise, that they have been such a good filter against me over the years that the same would apply to diesel...
 

Shayne

Well-Known Member
Guru
Joined
Feb 2, 2013
Messages
13,851
Ain’t nothing wrong with my sock and the tank looks brand new inside . As for the lines to the tank I think Krown rustproofing scored my truck about half a point lower than new . Has to be the primer failed .

DC38420D-4B8E-4A47-8FC2-005CC680F7AE.jpeg

I haven’t cleaned it yet .
 

karl webster

Land Cruiser Club sponsor
Promoted Company
Guru
Joined
May 20, 2010
Messages
5,667
I thought it would be like new. the rest of the truck is one of the best I've ever seen.

Just treat it to a genuine new primer mate and have 000s more trouble free miles.
 
Don't like the adverts?  Click here to remove them

karl webster

Land Cruiser Club sponsor
Promoted Company
Guru
Joined
May 20, 2010
Messages
5,667
I'll have a look in the stock pile mate. Pretty sure I'm out at the min though.
 

Shayne

Well-Known Member
Guru
Joined
Feb 2, 2013
Messages
13,851
may have fixed this with a squirt of ballistol but only time will tell .
 

Shayne

Well-Known Member
Guru
Joined
Feb 2, 2013
Messages
13,851
400 miles today and i reckon i'm going to forget about replacing the primer for a while . I didn't change the fuel filter on the previous service and its taken a long long time to do another 5000 miles so it might be 3 years since the primer was used and reckon the rubber seal just dried up some .

Perhaps removing the plunger cap to get a squirt of rubber restorer inside should be a preventative maintenance tip .
 
Top