1kz-te Rookie!

Beau

Well-Known Member
I am in guyana
Jan 28, 2011
2,004
290
83
Milton keynes
Congrats, glad it wasn't an expensive fix.

When she starts is she smoky out back or is the fumes pretty clear?
 

EldoradoSAM

Active Member
I am in guyana
Oct 30, 2018
64
5
8
Congrats, glad it wasn't an expensive fix.

When she starts is she smoky out back or is the fumes pretty clear?
Thanks Beau,so am I buddy. I’m very happy with the outcome so far.
Can be smokey yes. Grayish cloud...
I’ve noticed when I turn the key to on position and wait a few seconds I hear the brake cylinder spin. Pretty sure that’s what it is. The glow plug light comes on for a very short time maybe 1-2 seconds. I turn to start let it crank for a few seconds then stop and crank it again and it starts right away..
 

Beau

Well-Known Member
I am in guyana
Jan 28, 2011
2,004
290
83
Milton keynes
That's the ABS module cycling which is normal.

If possible, stick a clear line on the return line from the fuel pump and see if bubbles are in the line.
 

EldoradoSAM

Active Member
I am in guyana
Oct 30, 2018
64
5
8
Hey guys, I went on a trip a few weeks back and the truck preformed very well. However after I returned I stopped at the market and turned off the truck. When I came out and started I heard a grinding sound while it started... The next day when i tried to start again that grinding noise and nothing. Tried again and all I hear was the starter spinning but not turning over the engine...
My starter was shot... So I've since replaced it. But im still getting a hard start. Turns over quite a few times before starting...
@Beau I haven't tried the clear hose on the pump yet. I will get to it asap.
 
Last edited:
Don't like the adverts? Remove them by becoming a supporting member.   Click here

EldoradoSAM

Active Member
I am in guyana
Oct 30, 2018
64
5
8
Hey guys a quick update,
Did some research and found the vent valve for the fuel tank.
(after watching a video on the pressure released when opening your gas cap)
Turns out mine was completely blocked with mud from an outing...
I've cleaned that out and while I was at it I replace the fuel filter and primer pump on top.
That has solved the problem of pressure build-up in the tank.
The bad news is I still have a hard start...
I don't think there is a leak on the tank because there would never have been a pressure build-up in it.
I do believe this problem is fuel related but no proof as yet...
This is the valve that was blocked.
9091710067.jpg
 
Last edited:
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks