Push the buttom but won't engage 4 wheel drive

alanpayne

New Member
I am in uk
Jul 16, 2014
3
0
1
She won't engage into 4 wheel drive. When I press the button i can hear relays switch and The vacuum switches under the bonnet start to do something but no light comes on on the dash and does not go in gear. could it be the diaphragm that is conected to the gear box. is this a common fault. anyone else had this. help please. thanks
 

bigmac

New Member
I am in ireland
Feb 22, 2015
20
5
8
I have the same issue, when I push the 4high button or select low box .. and engage the hub locker both lights come on hub lock & 4 High light are on but its not in 4wheel drive

I haven't checked underneath on the transfer box yet but it must be the diapharm part... sticking form lack of use maybe..
 

Rich Sims

Well-Known Member
Sep 10, 2011
312
10
38
Bristol
Garage
How do you know its not in 4wd does the front prop shaft turn, It could be the front hubbs are playing up!
 

myers

New Member
I am in kenya
Feb 12, 2015
15
0
6
Nairobi, Kenya
I just installed manual hub locks on our kzj78.. the electronic hubs are prone to failure.. there are a few options out there for converting, but I bought AVM 463 hubs- they are a direct fit.. now I lock the hubs manually and then click the two buttons on the dash to put her in 4 wheel drive..
 
Don't like the adverts? Remove them by becoming a supporting member.   Click here
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock    No Thanks